読者です 読者をやめる 読者になる 読者になる

gaggitのブログ

コーディング、ガジェット、TIPS関連、FX

build.gradleのdependenciesのバージョンを知る方法

Android Studio、今日もいじってます(^^;なかなか、言うことをきいてくれません。前回、GooglePlayServicesのバージョン依存を解消するために関連するレポジトリのSDK Toolをアップデートしました。今後も、バージョン依存関係に悩まされないように関連していそうなSDK Toolで「Update Available」と出ているものは、アップデートしました。アップデート後、Runしたところ、案の定、正常にRunが終了してくれません。

アップデートしたので、build.gradleのdependenciesに記述されているバージョンを修正しました。

バージョンを知る方法は、以下です。

1.メニュー「File」「Project Structure」をクリックします。

2.左のメニュー「Modules」下の「app」をクリックします。

3.「Dependencies」タブをクリックします。

4.右上の「+」をクリックし、「Library dependency」をクリックします。

5.該当するライブラリを選択し、「OK」ボタンをクリックします。

f:id:gaggit:20160514224147p:plain

5.該当するライブラリの古いバージョンが存在する場合には、右側の矢印(上下)で古いライブラリの上に持っていくか、古いライブラリを削除します。

 6.build.gradleを開き、バージョンが修正されていることを確認します。

 

参照サイト:

[Android] Android Studioでサポートライブラリを導入する | Programming Style

p.s.

開発環境を改善するために近々、ノートPCのメモリを8GB→16GBに、通信環境を格安SIMの通信し放題から、固定回線(1Gbps)を導入予定です。

今日もがじがじっと~♪